<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script data-ad-client="ca-pub-5100951947531119" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="msvalidate.01" content="CF959D1B2342E71073B8A0BEA1429542" />
<meta name="yandex-verification" content="63c673903fad0874" />
<script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-5100951947531119",enable_page_level_ads:true});</script>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://stockwatch247.com/xmlrpc.php" />
<script>var et_site_url='https://stockwatch247.com';var et_post_id='29018';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script><title>Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North? &#8211; StockWatch247</title>
<meta property="og:type" content="article">
<meta property="og:title" content="Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?">
<meta property="og:site_name" content="StockWatch247">
<meta property="og:description" content="Raytheon Technologies Corporation (RTX), a Industrials Aerospace &amp; Defense corporation, saw its stock exchange 9,885,587 common shares, a higher demand">
<meta property="og:url" content="https://stockwatch247.com/2020/05/21/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north/">
<meta property="og:locale" content="en_US">
<meta property="og:image" content="https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX.jpg">
<meta property="og:image:height" content="2000">
<meta property="og:image:width" content="3000">
<meta property="article:published_time" content="2020-05-21T11:21:24+00:00">
<meta property="article:modified_time" content="2020-05-21T11:21:24+00:00">
<meta property="article:section" content="Small Cap">
<meta property="article:tag" content="buy stocks">
<meta property="article:tag" content="invest">
<meta property="article:tag" content="Raytheon Technologies Corporation (RTX)">
<meta property="article:tag" content="RTX">
<meta property="article:tag" content="sell stocks">
<meta property="article:tag" content="Stocks to Watch">
<meta property="article:tag" content="Top Stocks">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?">
<meta name="twitter:description" content="Raytheon Technologies Corporation (RTX), a Industrials Aerospace &amp; Defense corporation, saw its stock exchange 9,885,587 common shares, a higher demand">
<meta name="twitter:url" content="https://stockwatch247.com/2020/05/21/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north/">
<meta name="twitter:site" content="">
<meta name="twitter:image:src" content="https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX.jpg">
<meta name="twitter:image:width" content="3000">
<meta name="twitter:image:height" content="2000">
<script type="text/javascript">var jnews_ajax_url='https://stockwatch247.com/?ajax-request=jnews';</script>

<meta property="og:title" content="Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?" />
<meta property="og:description" content="Raytheon Technologies Corporation (RTX), a Industrials Aerospace &amp; Defense corporation, saw its stock exchange 9,885,587 common shares, a higher demand when com" />
<meta property="og:url" content="https://stockwatch247.com/2020/05/21/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north/" />
<meta property="og:image" content="https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX.jpg" />


<meta name="twitter:card" content="summary">
<meta name="twitter:title" content="Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?" />
<meta name="twitter:description" content="Raytheon Technologies Corporation (RTX), a Industrials Aerospace &amp; Defense corporation, saw its stock exchange 9,885,587 common shares, a higher demand when com" />
<meta name="twitter:image" content="https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX.jpg" />

<meta name="author" content="stockwatch247" />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="StockWatch247 &raquo; Feed" href="https://stockwatch247.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="StockWatch247 &raquo; Comments Feed" href="https://stockwatch247.com/comments/feed/" />
<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/stockwatch247.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://stockwatch247.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css' href='https://stockwatch247.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://stockwatch247.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-css' href='https://stockwatch247.com/wp-content/plugins/jnews-gallery/assets/css/previewslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-responsive-css' href='https://stockwatch247.com/wp-content/plugins/jnews-gallery/assets/css/previewslider-responsive.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Open+Sans%3Aregular%2C700%7CLora%3Aregular%2C700&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css' href='https://stockwatch247.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.13-9993131' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://stockwatch247.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css' href='https://stockwatch247.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=4.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css' href='https://stockwatch247.com/wp-content/themes/jnews/style.css?ver=4.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-scheme-css' href='https://stockwatch247.com/wp-content/themes/jnews/data/import/reportase/scheme.css?ver=4.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-dynamic-style-css' href="https://stockwatch247.com/wp-content/uploads/jeg/jeg-HJIsk120cC.css?ver=1.0.0" type='text/css' media='all' />
<link rel='stylesheet' id='jnews-social-login-style-css' href='https://stockwatch247.com/wp-content/plugins/jnews-social-login/assets/css/plugin.css?ver=4.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-weather-style-css' href='https://stockwatch247.com/wp-content/plugins/jnews-weather/assets/css/plugin.css?ver=4.0.0' type='text/css' media='all' />
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/jnews-gallery/assets/js/jquery.previewslider.js'></script>
<link rel='https://api.w.org/' href='https://stockwatch247.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://stockwatch247.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://stockwatch247.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.1" />
<link rel="canonical" href="https://stockwatch247.com/2020/05/21/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north/" />
<link rel='shortlink' href='https://stockwatch247.com/?p=29018' />
<link rel="alternate" type="application/json+oembed" href="https://stockwatch247.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://stockwatch247.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F&#038;format=xml" />
<style type="text/css" id="et-bloom-custom-css">.et_bloom .et_bloom_optin_1 .et_bloom_form_content{background-color:#424242!important}.et_bloom .et_bloom_optin_1 .et_bloom_form_container .et_bloom_form_header{background-color:#363636!important}.et_bloom .et_bloom_optin_1 .wedge_edge .triangle{fill:#363636}.et_bloom .et_bloom_optin_1 .et_bloom_form_content button{background-color:#81d742!important}.et_bloom .et_bloom_optin_1 .et_bloom_form_content .et_bloom_fields i{color:#81d742!important}.et_bloom .et_bloom_optin_1 .et_bloom_form_content .et_bloom_custom_field_radio i:before{background:#81d742!important}.et_bloom .et_bloom_optin_1 .et_bloom_form_content button{background-color:#81d742!important}.et_bloom .et_bloom_optin_1 .et_bloom_form_container h2,.et_bloom .et_bloom_optin_1 .et_bloom_form_container h2 span,.et_bloom .et_bloom_optin_1 .et_bloom_form_container h2 strong{font-family:"Open Sans",Helvetica,Arial,Lucida,sans-serif}.et_bloom .et_bloom_optin_1 .et_bloom_form_container p,.et_bloom .et_bloom_optin_1 .et_bloom_form_container p span,.et_bloom .et_bloom_optin_1 .et_bloom_form_container p strong,.et_bloom .et_bloom_optin_1 .et_bloom_form_container form input,.et_bloom .et_bloom_optin_1 .et_bloom_form_container form button span{font-family:"Open Sans",Helvetica,Arial,Lucida,sans-serif}</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://stockwatch247.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://stockwatch247.com/2020/05/21/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north/amp/"><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/stockwatch247.com\/#organization","url":"https:\/\/stockwatch247.com\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/web.facebook.com\/StockWatch247-1627886234022309","https:\/\/twitter.com\/StockWatch247"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/stockwatch247.com\/#website","url":"https:\/\/stockwatch247.com\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/stockwatch247.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-3946221723065824",enable_page_level_ads:true});</script> <style type="text/css" id="wp-custom-css">.grecaptcha-badge{display:none!important}.widget_text.footer_widget.widget_custom_html input[type="email"]{color:#fff!important}.jeg_menu_style_1 > li > a:before, .jeg_menu_style_2 > li > a:before, .jeg_menu_style_3 > li > a:before, .jeg_side_toggle, .jeg_slide_caption .jeg_post_category a, .jeg_slider_type_1 .owl-nav .owl-next, .jeg_block_heading_1 .jeg_block_title span, .jeg_block_heading_2 .jeg_block_title span, .jeg_block_heading_3, .jeg_block_heading_4 .jeg_block_title span, .jeg_block_heading_6:after, .jeg_pl_lg_box .jeg_post_category a, .jeg_pl_md_box .jeg_post_category a, .jeg_readmore:hover, .jeg_thumb .jeg_post_category a, .jeg_block_loadmore a:hover, .jeg_postblock.alt .jeg_block_loadmore a:hover, .jeg_block_loadmore a.active, .jeg_postblock_carousel_2 .jeg_post_category a, .jeg_heroblock .jeg_post_category a, .jeg_pagenav_1 .page_number.active, .jeg_pagenav_1 .page_number.active:hover, input[type="submit"], .btn, .button, .widget_tag_cloud a:hover, .popularpost_item:hover .jeg_post_title a:before, .jeg_splitpost_4 .page_nav, .jeg_splitpost_5 .page_nav, .jeg_post_via a:hover, .jeg_post_source a:hover, .jeg_post_tags a:hover, .comment-reply-title small a:before, .comment-reply-title small a:after, .jeg_storelist .productlink, .authorlink li.active a:before, .jeg_footer.dark .socials_widget:not(.nobg) a:hover .fa, .jeg_breakingnews_title, .jeg_overlay_slider_bottom.owl-carousel .owl-nav div, .jeg_overlay_slider_bottom.owl-carousel .owl-nav div:hover, .jeg_vertical_playlist .jeg_video_playlist_current, .woocommerce span.onsale, .woocommerce #respond input#submit:hover, .woocommerce a.button:hover, .woocommerce button.button:hover, .woocommerce input.button:hover, .woocommerce #respond input#submit.alt, .woocommerce a.button.alt, .woocommerce button.button.alt, .woocommerce input.button.alt, .jeg_popup_post .caption, .jeg_footer.dark input[type="submit"], .jeg_footer.dark .btn, .jeg_footer.dark .button, .footer_widget.widget_tag_cloud a:hover {background-color:#28ea9f!important}a, .jeg_menu_style_5 > li > a:hover, .jeg_menu_style_5 > li.sfHover > a, .jeg_menu_style_5 > li.current-menu-item > a, .jeg_menu_style_5 > li.current-menu-ancestor > a, .jeg_navbar .jeg_menu:not(.jeg_main_menu) > li > a:hover, .jeg_midbar .jeg_menu:not(.jeg_main_menu) > li > a:hover, .jeg_side_tabs li.active, .jeg_block_heading_5 strong, .jeg_block_heading_6 strong, .jeg_block_heading_7 strong, .jeg_block_heading_8 strong, .jeg_subcat_list li a:hover, .jeg_subcat_list li button:hover, .jeg_pl_lg_7 .jeg_thumb .jeg_post_category a, .jeg_pl_xs_2:before, .jeg_pl_xs_4 .jeg_postblock_content:before, .jeg_postblock .jeg_post_title a:hover, .jeg_hero_style_6 .jeg_post_title a:hover, .jeg_sidefeed .jeg_pl_xs_3 .jeg_post_title a:hover, .widget_jnews_popular .jeg_post_title a:hover, .jeg_meta_author a, .widget_archive li a:hover, .widget_pages li a:hover, .widget_meta li a:hover, .widget_recent_entries li a:hover, .widget_rss li a:hover, .widget_rss cite, .widget_categories li a:hover, .widget_categories li.current-cat > a, #breadcrumbs a:hover, .jeg_share_count .counts, .commentlist .bypostauthor > .comment-body > .comment-author > .fn, span.required, .jeg_review_title, .bestprice .price, .authorlink a:hover, .jeg_vertical_playlist .jeg_video_playlist_play_icon, .jeg_vertical_playlist .jeg_video_playlist_item.active .jeg_video_playlist_thumbnail:before, .jeg_horizontal_playlist .jeg_video_playlist_play, .woocommerce li.product .pricegroup .button, .widget_display_forums li a:hover, .widget_display_topics li:before, .widget_display_replies li:before, .widget_display_views li:before, .bbp-breadcrumb a:hover, .jeg_mobile_menu li.sfHover > a, .jeg_mobile_menu li a:hover, .split-template-6 .pagenum {color:#28ea9f}.jeg_author_socials a{font-size:16px;display:inline-block;margin:10px 10px 20px 0;color:#00d282;transition:all .2s ease-in-out}</style>
<noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head>
<body class="post-template-default single single-post postid-29018 single-format-standard et_bloom jeg_single_tpl_2 jnews jeg_boxed jsc_normal wpb-js-composer js-comp-ver-5.7 vc_responsive">
<div class="jeg_ad jeg_ad_top jnews_header_top_ads">
<div class='ads-wrapper  '></div> </div>

<div class="jeg_viewport">
<div class="jeg_header_wrapper">
<div class="jeg_header_instagram_wrapper">
</div>

<div class="jeg_header normal">
<div class="jeg_topbar jeg_container normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left  jeg_nav_grow">
<div class="item_wrap jeg_nav_alignleft">
</div>
</div>
<div class="jeg_nav_col jeg_nav_center  jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right  jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_top_date">
Thursday, May 21, 2020</div><div class="jnews_header_topbar_weather">
<div class="jeg_nav_item jeg_top_weather hide">
<div class="jeg_weather_condition">
<span class="jeg_weather_icon">
<i class="jegicon "></i>
</span>
</div>
<div class="jeg_weather_temp">
<span class="jeg_weather_value" data-temp-c="-18" data-temp-f="">-18</span>
<span class="jeg_weather_unit" data-unit="c">&deg;c</span>
</div>
<div class="jeg_weather_location">
<span></span>
</div>
<div class="jeg_weather_item hide temp item_4">
</div>
</div></div><div class="jeg_nav_item socials_widget jeg_social_icon_block square">
<a href="https://web.facebook.com/StockWatch247-1627886234022309" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/StockWatch247" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a></div><div class="jeg_nav_item jeg_nav_account">
<ul class="jeg_accountlink jeg_menu">
<li>
<i class="fa fa-spinner fa-spin fa-fw"></i>
</li>
</ul>
</div> </div>
</div>
</div>
</div>
</div><div class="jeg_midbar jeg_container normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo jeg_desktop_logo">
<div class="site-title">
<a href="https://stockwatch247.com/" style="padding: 0px 0px 0px 0px;">
<img src="https://www.stockwatch247.com/wp-content/uploads/2019/04/Screen-Shot-2019-04-24-at-12.44.40-AM.png" alt="StockWatch247"> </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
<div class='ads-wrapper  '><div class="ads_google_ads">
<style type='text/css' scoped>.adsslot_Hs4kDFcNVp{width:728px!important;height:90px!important}@media (max-width:1199px){.adsslot_Hs4kDFcNVp{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_Hs4kDFcNVp{width:320px!important;height:50px!important}}</style>
<ins class="adsbygoogle adsslot_Hs4kDFcNVp" style="display:inline-block;" data-ad-client="ca-pub-3946221723065824" data-ad-slot="9264983877"></ins>
<script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div></div></div> </div>
</div>
</div>
</div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal ">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-25069" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25069 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/active-stocks/">Active Stocks</a></li>
<li id="menu-item-25070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25070 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/earnings/">Earnings</a></li>
<li id="menu-item-25071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25071 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/new-issues-ipos/">New Issues &#8211; IPOs</a></li>
<li id="menu-item-25072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25072 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/stocks-to-watch/">Stocks To Watch</a></li>
<li id="menu-item-25073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25073 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/technology/">Technology</a></li>
<li id="menu-item-25127" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25127 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/top-performers/">Top Performers</a></li>
<li id="menu-item-26808" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-26808 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/small-cap/">Small Cap</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">

<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://stockwatch247.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div> </div>
<div class="jeg_header_sticky">
<div class="sticky_blankspace"></div>
<div class="jeg_header normal">
<div class="jeg_container">
<div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25069 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/active-stocks/">Active Stocks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25070 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/earnings/">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25071 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/new-issues-ipos/">New Issues &#8211; IPOs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25072 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/stocks-to-watch/">Stocks To Watch</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25073 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25127 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/top-performers/">Top Performers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-26808 bgnav" data-item-row="default"><a href="https://stockwatch247.com/category/small-cap/">Small Cap</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">

<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://stockwatch247.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div> </div>
</div>
</div>
</div>
<div class="jeg_navbar_mobile_wrapper">
<div class="jeg_navbar_mobile" data-mode="scroll">
<div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item">
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_mobile_logo">
<div class="site-title">
<a href="https://stockwatch247.com/">
StockWatch247 </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://stockwatch247.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div> </div> <div class="post-wrapper">
<div class="post-wrap">
<div class="jeg_main ">
<div class="jeg_container">
<div class="jeg_content jeg_singlepage">
<div class="container">
<div class="jeg_ad jeg_article_top jnews_article_top_ads">
<div class='ads-wrapper  '></div> </div>
<div class="jeg_breadcrumbs jeg_breadcrumb_container">
<div id="breadcrumbs"><span class="">
<a href="https://stockwatch247.com">Home</a>
</span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
<a href="https://stockwatch247.com/category/small-cap/">Small Cap</a>
</span></div> </div>
<div class="entry-header">
<h1 class="jeg_post_title">Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?</h1>
<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_2">
<div class="jeg_meta_author">
<span class="meta_text">by</span>
<a href="https://stockwatch247.com/author/stockwatch247/">stockwatch247</a> </div>
<div class="jeg_meta_date">
<a href="https://stockwatch247.com/2020/05/21/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north/">May 21, 2020</a>
</div>
<div class="jeg_meta_category">
<span><span class="meta_text">in</span>
<a href="https://stockwatch247.com/category/small-cap/" rel="category tag">Small Cap</a> </span>
</div>
<div class="jeg_meta_reading_time">
<span>
2 min read
</span>
</div>
<div class="meta_right">
<div class="jeg_meta_comment"><a href="https://stockwatch247.com/2020/05/21/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north/#respond"><i class="fa fa-comment-o"></i> 0</a></div>
</div>
</div>
</div>
</div>
<div class="row">
<div class="jeg_main_content col-md-8">
<div class="jeg_inner_content">
<div class="jeg_featured featured_image"><div class="thumbnail-container animate-lazy" style="padding-bottom:66.667%"><img width="750" height="500" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-featured-750 size-jnews-featured-750 lazyload wp-post-image" alt="NASDAQ:MSFT" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX-750x500.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX-750x500.jpg 750w, https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX-300x200.jpg 300w, https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX-768x512.jpg 768w, https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX-1024x683.jpg 1024w, https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX-1140x760.jpg 1140w" data-expand="700" /></div></div>
<div class="jeg_share_top_container"><div class="jeg_share_button clearfix">
<div class="jeg_share_stats">
</div>
<div class="jeg_sharelist">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Are+Shares+In+Raytheon+Technologies+Corporation+%28RTX%29+Ready+For+A+Move+North%3F+via+%40StockWatch247&url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="https://plus.google.com/share?url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F" rel='nofollow' class="jeg_btn-google-plus "><i class="fa fa-google-plus"></i></a>
<div class="share-secondary">
<a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F&title=Are+Shares+In+Raytheon+Technologies+Corporation+%28RTX%29+Ready+For+A+Move+North%3F" rel='nofollow' class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F&media=https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX.jpg&description=Are+Shares+In+Raytheon+Technologies+Corporation+%28RTX%29+Ready+For+A+Move+North%3F" rel='nofollow' class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a>
</div>
<a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
<div class="entry-content no-share">
<div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
<div class="jeg_share_float_container"></div> </div>
<div class="content-inner ">
<p>Raytheon Technologies Corporation (RTX), a Industrials Aerospace &#038; Defense corporation, saw its stock exchange 9,885,587 common shares, a higher demand when compared to its 10-day trading volume of 15.5M. Raytheon Technologies Corporation (RTX) stock is trading at $57.80, down -0.14 cents or -0.24% on the day. Based on this we can see some traders are either waiting on the sidelines to get involved or perhaps some are taking losses. Total Revenue for Raytheon Technologies Corporation (RTX) is $76.89B. Gross Profit is $20.21B and the EBITDA is $13.84B. </p>
<h4>Raytheon Technologies Corporation (RTX) Technical Statistics: </h4>
<p>The average 10-day trading volume of Raytheon Technologies Corporation (RTX) is 15.5M compared to 16.37M over the last 3 months which indicates a lower demand in trading activity. Right now, Raytheon Technologies Corporation (RTX) has a 50-day moving average of $60.16 and a 200-day moving average of $81.03. These moving averages are popular technical statistics that investors use to analyze price trends of Raytheon Technologies Corporation (RTX). Approximately 1.20% of the shares of the company are short sold from traders betting the shares will trade lower. The beta value of Raytheon Technologies Corporation (RTX) stock is 1.45, indicating its 4.26% to 3.72% more volatile than the overall marketplace. </p><div class='jnews_inline_related_post_wrapper right'>
<div class='jnews_inline_related_post'>
<div class="jeg_postblock_29 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_29018_0_5ec6762871af0   " data-unique="jnews_module_29018_0_5ec6762871af0">
<div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right">
<h3 class="jeg_block_title"><span>RELATED POSTS</span></h3>
</div>
<div class="jeg_block_container">
<div class="jeg_posts ">
<div class="jeg_postsmall jeg_load_more_flag">
<article class="jeg_post jeg_pl_xs post-28995 post type-post status-publish format-standard has-post-thumbnail hentry category-small-cap tag-ac tag-associated-capital-group tag-buy-stocks tag-inc-ac tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/05/21/will-associated-capital-group-inc-ac-beat-its-last-earnings-report/">Will Associated Capital Group, Inc. (AC) Beat Its Last Earnings Report?</a>
</h3>
</div>
</article><article class="jeg_post jeg_pl_xs post-29019 post type-post status-publish format-standard has-post-thumbnail hentry category-small-cap tag-buy-stocks tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks tag-verizon-communications-inc-vz tag-vz">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/05/21/is-wall-street-short-in-verizon-communications-inc-vz-stock/">Is Wall Street Short In Verizon Communications Inc. (VZ) Stock</a>
</h3>
</div>
</article>
</div>
</div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_29018_0_5ec6762871af0={"header_icon":"","first_title":"RELATED POSTS","second_title":"","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"2","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":29018,"include_category":"745","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","show_date":"","date_format":"ago","date_format_custom":"Y\/m\/d","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"2","pagination_scroll_limit":0,"ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","show_border":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_29"};</script>
</div>
</div>
</div>
<p> RTX is trading 41.98% off its 52 week low at $40.71 and -38.15% off its 52 week high of $93.45. Performance wise, RTX stock has recently shown investors 6.84% a higher demand in a week, -7.74% a lower demand in a month and -34.63% a lower demand in the past quarter. More importantly, Raytheon Technologies Corporation (RTX) has shown a return of -34.56% since the start of the year.</p>
<h4>Raytheon Technologies Corporation (RTX) Key Data: </h4>
<p>Raytheon Technologies Corporation (RTX) is a large-cap company with a market cap value of $87.576B. RTX insiders hold roughly 0.11% of the shares. On Apr-08-20 Vertical Research Initiated RTX as Hold at $58. On Apr-15-20 JP Morgan Downgrade RTX as Overweight → Neutral and on Apr-15-20 Goldman Resumed RTX as Buy at $76.</p>
<p>There are currently 1.51B shares in the float and 858.40M shares outstanding. There are 1.20% shares short in RTXs float. The industry rank for Raytheon Technologies Corporation (RTX) is 205 out of 254 ranking it at the Bottom 19% . </p>
<h4>Raytheon Technologies Corporation (RTX) Fundamental Evaluation: </h4>
<p>RTX last 2 years revenues have decreased from $77,046,000 to $76,891,000 showing a downtrend. Wall Street expects Raytheon Technologies Corporation (RTX) to report an EPS next Qtr profit of 0.30 and a profit of 31.07% next year. The growth rate on RTX this year is -57.51 compared to an industry -12.00. RTXs next year&#8217;s growth rate is 10.54 compared to an industry 6.50. The book value per share (mrq) is 45.91 and cash per share (mrq) is 5.17. Giving them a price/book (mrq) of 1.20 compared to an industry of 1.67 and RTXs price/cash flow (mrfy) is 4.58 compared to an industry of 5.62. RTX fundamental ratios shows an EPS growth vs. previous year 3.51 and EPS growth vs. previous quarter 0.39. </p>
<span class="et_bloom_bottom_trigger"></span>
<div class="jeg_post_tags"><span>Tags:</span> <a href="https://stockwatch247.com/tag/buy-stocks/" rel="tag">buy stocks</a><a href="https://stockwatch247.com/tag/invest/" rel="tag">invest</a><a href="https://stockwatch247.com/tag/raytheon-technologies-corporation-rtx/" rel="tag">Raytheon Technologies Corporation (RTX)</a><a href="https://stockwatch247.com/tag/rtx/" rel="tag">RTX</a><a href="https://stockwatch247.com/tag/sell-stocks/" rel="tag">sell stocks</a><a href="https://stockwatch247.com/tag/stocks-to-watch/" rel="tag">Stocks to Watch</a><a href="https://stockwatch247.com/tag/top-stocks/" rel="tag">Top Stocks</a></div>
</div>
<div class="jeg_share_bottom_container"><div class="jeg_share_button share-bottom clearfix">
<div class="jeg_sharelist">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share</span></a><a href="https://twitter.com/intent/tweet?text=Are+Shares+In+Raytheon+Technologies+Corporation+%28RTX%29+Ready+For+A+Move+North%3F+via+%40StockWatch247&url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Tweet</span></a><a href="https://plus.google.com/share?url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F" rel='nofollow' class="jeg_btn-google-plus expanded"><i class="fa fa-google-plus"></i><span>Share</span></a>
<div class="share-secondary">
<a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F&title=Are+Shares+In+Raytheon+Technologies+Corporation+%28RTX%29+Ready+For+A+Move+North%3F" rel='nofollow' class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fstockwatch247.com%2F2020%2F05%2F21%2Fare-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north%2F&media=https://stockwatch247.com/wp-content/uploads/2019/04/young-manager-has-received-good-bad-news-UGBDSNX.jpg&description=Are+Shares+In+Raytheon+Technologies+Corporation+%28RTX%29+Ready+For+A+Move+North%3F" rel='nofollow' class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a>
</div>
<a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
</div>
</div></div>
</div>
<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div class="jeg_postblock_5 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_29018_1_5ec6762873fd1   " data-unique="jnews_module_29018_1_5ec6762873fd1">
<div class="jeg_block_heading jeg_block_heading_9 jeg_subcat_right">
<h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
</div>
<div class="jeg_block_container">
<div class="jeg_posts jeg_load_more_flag">
<article class="jeg_post jeg_pl_lg_2 post-28995 post type-post status-publish format-standard has-post-thumbnail hentry category-small-cap tag-ac tag-associated-capital-group tag-buy-stocks tag-inc-ac tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks">
<div class="jeg_thumb">
<a href="https://stockwatch247.com/2020/05/21/will-associated-capital-group-inc-ac-beat-its-last-earnings-report/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/money-in-burlap-sack-on-wooden-background-7GLC6HW-350x250.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/money-in-burlap-sack-on-wooden-background-7GLC6HW-350x250.jpg 350w, https://stockwatch247.com/wp-content/uploads/2019/04/money-in-burlap-sack-on-wooden-background-7GLC6HW-120x86.jpg 120w, https://stockwatch247.com/wp-content/uploads/2019/04/money-in-burlap-sack-on-wooden-background-7GLC6HW-750x536.jpg 750w, https://stockwatch247.com/wp-content/uploads/2019/04/money-in-burlap-sack-on-wooden-background-7GLC6HW-1140x815.jpg 1140w" data-expand="700" /></div></a>
<div class="jeg_post_category">
<span><a href="https://stockwatch247.com/category/small-cap/" class="category-small-cap">Small Cap</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/05/21/will-associated-capital-group-inc-ac-beat-its-last-earnings-report/">Will Associated Capital Group, Inc. (AC) Beat Its Last Earnings Report?</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://stockwatch247.com/author/stockwatch247/">stockwatch247</a></div><div class="jeg_meta_date"><a href="https://stockwatch247.com/2020/05/21/will-associated-capital-group-inc-ac-beat-its-last-earnings-report/"><i class="fa fa-clock-o"></i> 4 hours ago</a></div></div>
<div class="jeg_post_excerpt">
<p>Associated Capital Group, Inc. (AC), a Financial Services Capital Markets business, saw its stock exchange 8,807 shares, a lower demand...</p>
<a href="https://stockwatch247.com/2020/05/21/will-associated-capital-group-inc-ac-beat-its-last-earnings-report/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post jeg_pl_lg_2 post-29019 post type-post status-publish format-standard has-post-thumbnail hentry category-small-cap tag-buy-stocks tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks tag-verizon-communications-inc-vz tag-vz">
<div class="jeg_thumb">
<a href="https://stockwatch247.com/2020/05/21/is-wall-street-short-in-verizon-communications-inc-vz-stock/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/group-of-entrepreneur-analysing-for-investment-in-P86P7WY-350x250.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/group-of-entrepreneur-analysing-for-investment-in-P86P7WY-350x250.jpg 350w, https://stockwatch247.com/wp-content/uploads/2019/04/group-of-entrepreneur-analysing-for-investment-in-P86P7WY-120x86.jpg 120w, https://stockwatch247.com/wp-content/uploads/2019/04/group-of-entrepreneur-analysing-for-investment-in-P86P7WY-750x536.jpg 750w, https://stockwatch247.com/wp-content/uploads/2019/04/group-of-entrepreneur-analysing-for-investment-in-P86P7WY-1140x815.jpg 1140w" data-expand="700" /></div></a>
<div class="jeg_post_category">
<span><a href="https://stockwatch247.com/category/small-cap/" class="category-small-cap">Small Cap</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/05/21/is-wall-street-short-in-verizon-communications-inc-vz-stock/">Is Wall Street Short In Verizon Communications Inc. (VZ) Stock</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://stockwatch247.com/author/stockwatch247/">stockwatch247</a></div><div class="jeg_meta_date"><a href="https://stockwatch247.com/2020/05/21/is-wall-street-short-in-verizon-communications-inc-vz-stock/"><i class="fa fa-clock-o"></i> 4 hours ago</a></div></div>
<div class="jeg_post_excerpt">
<p>Verizon Communications Inc. (VZ), a Communication Services Telecom Services corporation, saw its stock trade 20,432,274 shares, a greater amount when...</p>
<a href="https://stockwatch247.com/2020/05/21/is-wall-street-short-in-verizon-communications-inc-vz-stock/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post jeg_pl_lg_2 post-28955 post type-post status-publish format-standard has-post-thumbnail hentry category-small-cap tag-buy-stocks tag-hes tag-hess-corporation-hes tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks">
<div class="jeg_thumb">
<a href="https://stockwatch247.com/2020/05/18/breaking-news-hess-corporation-hes-posts-record-news-stocks-continues-to-climb/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-hundred-dollar-bills-PVHU764-350x250.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-hundred-dollar-bills-PVHU764-350x250.jpg 350w, https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-hundred-dollar-bills-PVHU764-120x86.jpg 120w, https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-hundred-dollar-bills-PVHU764-750x536.jpg 750w, https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-hundred-dollar-bills-PVHU764-1140x815.jpg 1140w" data-expand="700" /></div></a>
<div class="jeg_post_category">
<span><a href="https://stockwatch247.com/category/small-cap/" class="category-small-cap">Small Cap</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/05/18/breaking-news-hess-corporation-hes-posts-record-news-stocks-continues-to-climb/">Breaking News: Hess Corporation (HES) Posts Record News, Stocks Continues To Climb</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://stockwatch247.com/author/stockwatch247/">stockwatch247</a></div><div class="jeg_meta_date"><a href="https://stockwatch247.com/2020/05/18/breaking-news-hess-corporation-hes-posts-record-news-stocks-continues-to-climb/"><i class="fa fa-clock-o"></i> 3 days ago</a></div></div>
<div class="jeg_post_excerpt">
<p>Hess Corporation (HES), a Energy Oil & Gas E&P organization, saw its stock exchange 2,604,936 shares, a higher demand against...</p>
<a href="https://stockwatch247.com/2020/05/18/breaking-news-hess-corporation-hes-posts-record-news-stocks-continues-to-climb/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post jeg_pl_lg_2 post-28947 post type-post status-publish format-standard has-post-thumbnail hentry category-small-cap tag-buy-stocks tag-cns tag-cohen-steers tag-inc-cns tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks">
<div class="jeg_thumb">
<a href="https://stockwatch247.com/2020/05/18/the-market-took-the-recent-news-on-cohen-steers-inc-cns-as-negative/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/businessman-reading-newspaper-in-the-morning-PUZVPT8-350x250.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/businessman-reading-newspaper-in-the-morning-PUZVPT8-350x250.jpg 350w, https://stockwatch247.com/wp-content/uploads/2019/04/businessman-reading-newspaper-in-the-morning-PUZVPT8-120x86.jpg 120w, https://stockwatch247.com/wp-content/uploads/2019/04/businessman-reading-newspaper-in-the-morning-PUZVPT8-750x536.jpg 750w, https://stockwatch247.com/wp-content/uploads/2019/04/businessman-reading-newspaper-in-the-morning-PUZVPT8-1140x815.jpg 1140w" data-expand="700" /></div></a>
<div class="jeg_post_category">
<span><a href="https://stockwatch247.com/category/small-cap/" class="category-small-cap">Small Cap</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/05/18/the-market-took-the-recent-news-on-cohen-steers-inc-cns-as-negative/">The Market Took The Recent News on Cohen &#038; Steers, Inc. (CNS) As Negative</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://stockwatch247.com/author/stockwatch247/">stockwatch247</a></div><div class="jeg_meta_date"><a href="https://stockwatch247.com/2020/05/18/the-market-took-the-recent-news-on-cohen-steers-inc-cns-as-negative/"><i class="fa fa-clock-o"></i> 3 days ago</a></div></div>
<div class="jeg_post_excerpt">
<p>Cohen & Steers, Inc. (CNS), a Financial Services Asset Management corporation, saw its stock trade 592,007 common shares, a spike...</p>
<a href="https://stockwatch247.com/2020/05/18/the-market-took-the-recent-news-on-cohen-steers-inc-cns-as-negative/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post jeg_pl_lg_2 post-28924 post type-post status-publish format-standard has-post-thumbnail hentry category-small-cap tag-buy-stocks tag-inc-jill tag-invest tag-j-jill tag-jill tag-sell-stocks tag-stocks-to-watch tag-top-stocks">
<div class="jeg_thumb">
<a href="https://stockwatch247.com/2020/05/15/technical-data-points-to-why-j-jill-inc-jill-shares-traded-down/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/business-concepts-businessman-holding-a-pen-D8MNGZW-350x250.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/business-concepts-businessman-holding-a-pen-D8MNGZW-350x250.jpg 350w, https://stockwatch247.com/wp-content/uploads/2019/04/business-concepts-businessman-holding-a-pen-D8MNGZW-120x86.jpg 120w, https://stockwatch247.com/wp-content/uploads/2019/04/business-concepts-businessman-holding-a-pen-D8MNGZW-750x536.jpg 750w, https://stockwatch247.com/wp-content/uploads/2019/04/business-concepts-businessman-holding-a-pen-D8MNGZW-1140x815.jpg 1140w" data-expand="700" /></div></a>
<div class="jeg_post_category">
<span><a href="https://stockwatch247.com/category/small-cap/" class="category-small-cap">Small Cap</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/05/15/technical-data-points-to-why-j-jill-inc-jill-shares-traded-down/">Technical Data Points To Why J.Jill, Inc. (JILL) Shares Traded Down</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://stockwatch247.com/author/stockwatch247/">stockwatch247</a></div><div class="jeg_meta_date"><a href="https://stockwatch247.com/2020/05/15/technical-data-points-to-why-j-jill-inc-jill-shares-traded-down/"><i class="fa fa-clock-o"></i> 6 days ago</a></div></div>
<div class="jeg_post_excerpt">
<p>J.Jill, Inc. (JILL), a Consumer Cyclical Apparel Retail organization, saw its stock trade 775,706 shares, decrease when compared to its...</p>
<a href="https://stockwatch247.com/2020/05/15/technical-data-points-to-why-j-jill-inc-jill-shares-traded-down/" class="jeg_readmore">Read more</a>
</div>
</div>
</article>
</div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_29018_1_5ec6762873fd1={"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_9","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"5","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":29018,"include_category":"745","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"ago","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"5","pagination_scroll_limit":3,"ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_5"};</script>
</div></div><div class="jnews_popup_post_container">
<section class="jeg_popup_post">
<span class="caption">Next Post</span>
<div class="jeg_popup_content">
<div class="jeg_thumb">
<a href="https://stockwatch247.com/2020/05/21/trader-alert-mfa-financial-inc-mfa-trades-up-perhaps-it-will-break-out/">
<div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-50-euro-banknote-PNCFQDS-75x75.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-50-euro-banknote-PNCFQDS-75x75.jpg 75w, https://stockwatch247.com/wp-content/uploads/2019/04/closeup-of-50-euro-banknote-PNCFQDS-150x150.jpg 150w" data-expand="700" /></div> </a>
</div>
<h3 class="post-title">
<a href="https://stockwatch247.com/2020/05/21/trader-alert-mfa-financial-inc-mfa-trades-up-perhaps-it-will-break-out/">
Trader Alert: MFA Financial, Inc. (MFA) Trades Up, Perhaps It Will Break Out </a>
</h3>
</div>
<a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
</section>
</div><div class="jnews_comment_container"></div> </div>
</div>
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
<div class="widget widget_jnews_popular" id="jnews_popular-1"><div class="jeg_block_heading jeg_block_heading_9 jnews_5ec6762877f72"><h3 class="jeg_block_title"><span>MOST VIEWED</span></h3></div><ul class="popularpost_list"><li class="popularpost_item post-24471 post type-post status-publish format-standard has-post-thumbnail hentry category-technology tag-amazon tag-amzn tag-nasdaqamzn">
<div class="jeg_thumb">
<a href="https://stockwatch247.com/2019/04/11/amazon-amzn-amazon-likely-to-stay-bullish-this-quarter-the-fundamentals-support-it/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://stockwatch247.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" data-src="https://stockwatch247.com/wp-content/uploads/2019/04/piggy-moneybox-with-dollar-cash-PZB7KN7-350x250.jpg" data-sizes="auto" data-srcset="https://stockwatch247.com/wp-content/uploads/2019/04/piggy-moneybox-with-dollar-cash-PZB7KN7-350x250.jpg 350w, https://stockwatch247.com/wp-content/uploads/2019/04/piggy-moneybox-with-dollar-cash-PZB7KN7-120x86.jpg 120w, https://stockwatch247.com/wp-content/uploads/2019/04/piggy-moneybox-with-dollar-cash-PZB7KN7-750x536.jpg 750w, https://stockwatch247.com/wp-content/uploads/2019/04/piggy-moneybox-with-dollar-cash-PZB7KN7-1140x815.jpg 1140w" data-expand="700" /></div></a>
</div>
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2019/04/11/amazon-amzn-amazon-likely-to-stay-bullish-this-quarter-the-fundamentals-support-it/" data-num="01">Amazon (AMZN) – Amazon likely to stay bullish this quarter: The fundamentals support it</a>
</h3>
<div class="popularpost_meta">
<div class="jeg_socialshare">
<span class="share_count"><i class="fa fa-share-alt"></i> 1 shares</span>
<div class="socialshare_list">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fstockwatch247.com%2F2019%2F04%2F11%2Famazon-amzn-amazon-likely-to-stay-bullish-this-quarter-the-fundamentals-support-it%2F" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">1</span></a>
<a href="https://twitter.com/intent/tweet?text=Amazon+%28AMZN%29+%E2%80%93++Amazon+likely+to+stay+bullish+this+quarter%3A+The+fundamentals+support+it+via+%40StockWatch247&url=https%3A%2F%2Fstockwatch247.com%2F2019%2F04%2F11%2Famazon-amzn-amazon-likely-to-stay-bullish-this-quarter-the-fundamentals-support-it%2F" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
</div>
</div>
</div>
</li><li class="popularpost_item post-27188 post type-post status-publish format-standard has-post-thumbnail hentry category-active-stocks tag-myo tag-myomo">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/02/04/heres-why-you-should-hold-on-to-myomo-inc-nysemyo-stock-for-now/" data-num="02">Here&#8217;s Why You Should Hold on to Myomo, Inc. (NYSE:MYO) Stock for Now</a>
</h3>
<div class="popularpost_meta">
<div class="jeg_socialshare">
<span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
<div class="socialshare_list">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fstockwatch247.com%2F2020%2F02%2F04%2Fheres-why-you-should-hold-on-to-myomo-inc-nysemyo-stock-for-now%2F" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
<a href="https://twitter.com/intent/tweet?text=Here%E2%80%99s+Why+You+Should+Hold+on+to+Myomo%2C+Inc.+%28NYSE%3AMYO%29+Stock+for+Now+via+%40StockWatch247&url=https%3A%2F%2Fstockwatch247.com%2F2020%2F02%2F04%2Fheres-why-you-should-hold-on-to-myomo-inc-nysemyo-stock-for-now%2F" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
</div>
</div>
</div>
</li><li class="popularpost_item post-25762 post type-post status-publish format-standard has-post-thumbnail hentry category-active-stocks tag-nasdaq-stock-trading tag-nasdaq-fcel tag-pre-market-trading tag-stocks-to-trade tag-stocks-to-watch tag-trading-nasdaq-stocks">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2019/07/02/fuelcell-energy-fcel-gains-by-over-10-in-pre-market-trading/" data-num="03">FuelCell Energy (FCEL) Gains by Over 10% in Pre-market Trading</a>
</h3>
<div class="popularpost_meta">
<div class="jeg_socialshare">
<span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
<div class="socialshare_list">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fstockwatch247.com%2F2019%2F07%2F02%2Ffuelcell-energy-fcel-gains-by-over-10-in-pre-market-trading%2F" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
<a href="https://twitter.com/intent/tweet?text=FuelCell+Energy+%28FCEL%29+Gains+by+Over+10%25+in+Pre-market+Trading+via+%40StockWatch247&url=https%3A%2F%2Fstockwatch247.com%2F2019%2F07%2F02%2Ffuelcell-energy-fcel-gains-by-over-10-in-pre-market-trading%2F" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
</div>
</div>
</div>
</li><li class="popularpost_item post-27183 post type-post status-publish format-standard has-post-thumbnail hentry category-stocks-to-watch tag-ibio tag-nyseibio">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/02/04/ibio-inc-nyseibio-can-be-a-good-stock-for-investors/" data-num="04">iBio, Inc. (NYSE:IBIO) can be a good stock for investors.</a>
</h3>
<div class="popularpost_meta">
<div class="jeg_socialshare">
<span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
<div class="socialshare_list">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fstockwatch247.com%2F2020%2F02%2F04%2Fibio-inc-nyseibio-can-be-a-good-stock-for-investors%2F" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
<a href="https://twitter.com/intent/tweet?text=iBio%2C+Inc.+%28NYSE%3AIBIO%29+can+be+a+good+stock+for+investors.+via+%40StockWatch247&url=https%3A%2F%2Fstockwatch247.com%2F2020%2F02%2F04%2Fibio-inc-nyseibio-can-be-a-good-stock-for-investors%2F" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
</div>
</div>
</div>
</li><li class="popularpost_item post-25084 post type-post status-publish format-standard has-post-thumbnail hentry category-new-issues-ipos category-stocks-to-watch tag-day-trade tag-initial-public-offering tag-ipo tag-ipos tag-jmia tag-jumia-technologies-ag tag-nysejmia tag-swing-trade">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2019/04/19/jumia-technologies-ag-jmia-after-ipo-surge-ends-as-the-ttock-sees-a-13-slump/" data-num="05">JUMIA TECHNOLOGIES AG (JMIA) After IPO Surge Ends as The Stock Sees a 13% Slump</a>
</h3>
<div class="popularpost_meta">
<div class="jeg_socialshare">
<span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
<div class="socialshare_list">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fstockwatch247.com%2F2019%2F04%2F19%2Fjumia-technologies-ag-jmia-after-ipo-surge-ends-as-the-ttock-sees-a-13-slump%2F" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
<a href="https://twitter.com/intent/tweet?text=JUMIA+TECHNOLOGIES+AG+%28JMIA%29+After+IPO+Surge+Ends+as+The+Stock+Sees+a+13%25+Slump+via+%40StockWatch247&url=https%3A%2F%2Fstockwatch247.com%2F2019%2F04%2F19%2Fjumia-technologies-ag-jmia-after-ipo-surge-ends-as-the-ttock-sees-a-13-slump%2F" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
</div>
</div>
</div>
</li></ul></div></div> </div>
<div class="jeg_ad jeg_article jnews_article_bottom_ads">
<div class='ads-wrapper  '></div> </div>
</div>
</div>
</div>
</div>
<div id="post-body-class" class="post-template-default single single-post postid-29018 single-format-standard et_bloom jeg_single_tpl_2 jnews jeg_boxed jsc_normal wpb-js-composer js-comp-ver-5.7 vc_responsive"></div>
</div>
<div class="post-ajax-overlay">
<div class="preloader_type preloader_dot">
<div class="newsfeed_preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="newsfeed_preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="newsfeed_preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="footer-holder" id="footer" data-id="footer">
<div class="jeg_footer jeg_footer_3 dark">
<div class="jeg_footer_container jeg_container">
<div class="jeg_footer_content">
<div class="container">
<div class="row">
<div class="jeg_footer_primary clearfix">
<div class="col-md-3 footer_column">
<div class="footer_widget widget_jnews_about" id="jnews_about-1"> <div class="jeg_about ">
<h2 class="jeg_about_name">Stock Watch 247</h2> <p>Stock Watch 247 is a leading provider and publisher of stock market news, initial public offering (IPO) news, new stock listings and stocks to watch, commentary, business news, financial news and content on the USA & World Markets. Stock Watch 247 is for information only and not investment advice. Please make sure to read our <a href="https://www.stockwatch247.com/disclaimer/">Disclaimer</a> and <a href="https://www.stockwatch247.com/privacy-policy/">Privacy Policy</a>. We may be buying or selling any stock discussed at any time.</p>
</div>
</div><div class="footer_widget widget_jnews_social" id="jnews_social-2">
<div class="jeg_social_wrap ">
<div class="socials_widget   nobg">
<a href="https://www.facebook.com/stockwatch247/" target="_blank" class="jeg_facebook">
<i class="fa fa-facebook"></i>
</a><a href="https://twitter.com/stockwatch247" target="_blank" class="jeg_twitter">
<i class="fa fa-twitter"></i>
</a><a href="https://instagram.com/stockwatch247/" target="_blank" class="jeg_instagram">
<i class="fa fa-instagram"></i>
</a> </div>
</div>
</div> </div>
<div class="col-md-3 footer_column">
<div class="footer_widget widget_nav_menu" id="nav_menu-2"><div class="jeg_footer_heading jeg_footer_heading_1"><h3 class="jeg_footer_title"><span>Categories</span></h3></div><div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25069"><a href="https://stockwatch247.com/category/active-stocks/">Active Stocks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25070"><a href="https://stockwatch247.com/category/earnings/">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25071"><a href="https://stockwatch247.com/category/new-issues-ipos/">New Issues &#8211; IPOs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25072"><a href="https://stockwatch247.com/category/stocks-to-watch/">Stocks To Watch</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25073"><a href="https://stockwatch247.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25127"><a href="https://stockwatch247.com/category/top-performers/">Top Performers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-26808"><a href="https://stockwatch247.com/category/small-cap/">Small Cap</a></li>
</ul></div></div> </div>
<div class="col-md-3 footer_column">
<div class="footer_widget widget_jnews_module_block_28" id="jnews_module_block_28-2"><div class="jeg_postblock_28 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_29018_2_5ec676287d31c  normal " data-unique="jnews_module_29018_2_5ec676287d31c">
<div class="jeg_block_container">
<div class="jeg_posts ">
<div class="jeg_postsmall jeg_load_more_flag">
<article class="jeg_post jeg_pl_xs_4 post-27338 post type-post status-publish format-standard has-post-thumbnail hentry category-new-issues tag-buy-stocks tag-invest tag-sell-stocks tag-snap tag-snap-inc-snap tag-stocks-to-watch tag-top-stocks">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/02/18/are-traders-looking-to-short-shares-of-snap-inc-snap/">Are Traders Looking To Short Shares of Snap Inc. (SNAP)</a>
</h3>
</div>
</article><article class="jeg_post jeg_pl_xs_4 post-26251 post type-post status-publish format-standard has-post-thumbnail hentry category-active-stocks category-earnings tag-active-stocks tag-nyse-el tag-pre-market-stocks-to-watch tag-short-term-investing tag-short-term-trading-stocks tag-stock-earnings-report tag-swing-trade-stocks-charts">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2019/08/20/the-estee-lauder-companies-el-beats-analysts-expectations-for-q4-projects-strong-growth-in-fiscal-2020/">The Estée Lauder Companies (EL) Beats Analysts’ Expectations for Q4 &#8211; Projects Strong Growth in Fiscal 2020</a>
</h3>
</div>
</article><article class="jeg_post jeg_pl_xs_4 post-28163 post type-post status-publish format-standard has-post-thumbnail hentry category-stocks-to-watch tag-buy-stocks tag-invest tag-marathon-oil-corporation-mro tag-mro tag-sell-stocks tag-stocks-to-watch tag-top-stocks">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/03/31/make-sure-to-read-key-chart-data-before-trading-marathon-oil-corporation-mro/">Make Sure To Read Key Chart Data Before Trading Marathon Oil Corporation (MRO)</a>
</h3>
</div>
</article><article class="jeg_post jeg_pl_xs_4 post-27663 post type-post status-publish format-standard has-post-thumbnail hentry category-stocks-to-watch tag-buy-stocks tag-inc-uber tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks tag-uber tag-uber-technologies">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/02/28/is-now-the-right-time-to-sit-on-the-sidelines-with-uber-technologies-inc-uber/">Is Now The Right Time To Sit On the Sidelines With Uber Technologies, Inc. (UBER)</a>
</h3>
</div>
</article><article class="jeg_post jeg_pl_xs_4 post-25802 post type-post status-publish format-standard has-post-thumbnail hentry category-stocks-to-watch category-technology tag-nasdaq-amd tag-stocks-to-trade tag-stocks-to-watch tag-swing-trade-stocks tag-swing-trading-stocks tag-trading-stocks-charts">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2019/07/08/stocks-to-watch-advanced-micro-devices-amd-launches-ultimate-pc-gaming-platform/">Stocks to Watch: Advanced Micro Devices (AMD) Launches Ultimate PC Gaming Platform</a>
</h3>
</div>
</article><article class="jeg_post jeg_pl_xs_4 post-27779 post type-post status-publish format-standard has-post-thumbnail hentry category-top-performers tag-bcrx tag-biocryst-pharmaceuticals tag-buy-stocks tag-inc-bcrx tag-invest tag-sell-stocks tag-stocks-to-watch tag-top-stocks">
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://stockwatch247.com/2020/03/05/biocryst-pharmaceuticals-inc-bcrx-rallies-on-positive-market-update/">BioCryst Pharmaceuticals, Inc. (BCRX) Rallies on Positive Market Update</a>
</h3>
</div>
</article>
</div>
</div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
 <div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_29018_2_5ec676287d31c={"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"6","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"random","show_date":"","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":"0","ads_type":"disable","ads_position":"1","ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","show_border":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_28"};</script>
</div></div> </div>
<div class="col-md-3 footer_column">
<div class="widget_text footer_widget widget_custom_html" id="custom_html-2"><div class="jeg_footer_heading jeg_footer_heading_1"><h3 class="jeg_footer_title"><span>SUBSCRIBE TO OUR FREE VIP NEWSLETTER: Get Trade Reports, Ideas, Breaking News and more! </span></h3></div><div class="textwidget custom-html-widget"><script type="text/javascript" src="//app.icontact.com/icp/core/mycontacts/signup/designer/form/automatic?id=271&cid=1777436&lid=9689"></script>
<p style="text-align:center;"><span style="color: rgb(255,255,255);font-size: 11px;font-family: Lato;">By clicking "Subscribe Now" You agree to our </span><a href="https://www.stockwatch247.com/privacy-policy/" target="_blank" rel="noopener noreferrer"><span style="color: rgb(255,255,255);font-size: 11px;font-family: Lato;"><ins>Privacy Policy</ins></span></a><span style="color: rgb(255,255,255);font-size: 11px;font-family: Lato;"> &amp; </span><a href="https://www.stockwatch247.com/disclaimer/" target="_blank" rel="noopener noreferrer"><span style="color: rgb(255,255,255);font-size: 11px;font-family: Lato;"><ins>Disclaimer</ins></span></a><span style="color: rgb(255,255,255);font-size: 11px;font-family: Lato;">. We are 100% Anti-Spam.</span></p></div></div> </div>
</div>
</div>
</div>
</div>
<div class="jeg_footer_bottom clearfix">
<div class="container">

<div class="footer_right">
<ul class="jeg_menu_footer"><li id="menu-item-24528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24528"><a href="https://stockwatch247.com/about-us/">About Us</a></li>
<li id="menu-item-24527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24527"><a href="https://stockwatch247.com/our-team/">Our Team</a></li>
<li id="menu-item-24529" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24529"><a href="https://stockwatch247.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-24530" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24530"><a href="https://stockwatch247.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-24531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24531"><a href="https://stockwatch247.com/contact-us/">Contact Us</a></li>
</ul>
</div>

<p class="copyright"> Powered by <a target="_blank" href="https://mktsnews.com">Market News -
</a>
© 2019 <a href="http://jegtheme.com" title="StockWatch247">StockWatch247</a> - Copyright © All Rights Reserved. </p>
</div>
</div>
</div>
</div> </div>
<div class="jscroll-to-top">
<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
</div>
</div>

<div id="jeg_off_canvas" class="normal">
<a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
<div class="jeg_bg_overlay"></div>
<div class="jeg_mobile_wrapper">
<div class="nav_wrap">
<div class="item_main">

<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand square">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://stockwatch247.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class="jeg_aside_item">
<ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25069"><a href="https://stockwatch247.com/category/active-stocks/">Active Stocks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25070"><a href="https://stockwatch247.com/category/earnings/">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25071"><a href="https://stockwatch247.com/category/new-issues-ipos/">New Issues &#8211; IPOs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25072"><a href="https://stockwatch247.com/category/stocks-to-watch/">Stocks To Watch</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25073"><a href="https://stockwatch247.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25127"><a href="https://stockwatch247.com/category/top-performers/">Top Performers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-26808"><a href="https://stockwatch247.com/category/small-cap/">Small Cap</a></li>
</ul></div> </div>
<div class="item_bottom">
<div class="jeg_aside_item socials_widget square">
<a href="https://web.facebook.com/StockWatch247-1627886234022309" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/StockWatch247" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
<p>Powered by <a target="_blank" href="https://mktsnews.com">Market News -
</a>
© 2019 <a href="http://jegtheme.com" title="StockWatch247">StockWatch247</a> - Copyright © All Rights Reserved.</p>
</div> </div>
</div> </div>
</div>
<div id="jeg_loginform" class="jeg_popup mfp-with-anim mfp-hide">
<div class="jeg_popupform">
<form action="#" method="post" accept-charset="utf-8">
<p>Login to your account below</p>

<div class="form-message"></div>
<p class="input_field">
<input type="text" name="username" placeholder="Username" value="">
</p>
<p class="input_field">
<input type="password" name="password" placeholder="Password" value="">
</p>
<p class="submit">
<input type="hidden" name="action" value="login_handler">
<input type="hidden" name="jnews_nonce" value="a1c68fcdaa">
<input type="submit" name="jeg_login_button" class="button" value="Log In" data-process="Processing . . ." data-string="Log In">
</p>
<div class="bottom_links clearfix">
<a href="#jeg_forgotform" class="jeg_popuplink forgot">Forgotten Password?</a>
</div>
</form>
</div>
</div>

<div id="jeg_registerform" class="jeg_popup mfp-with-anim mfp-hide">
<div class="jeg_popupform">
<form action="#" method="post" accept-charset="utf-8">
<p>Fill the forms bellow to register</p>

<div class="form-message"></div>
<p class="input_field">
<input type="text" name="email" placeholder="Your email" value="">
</p>
<p class="input_field">
<input type="text" name="username" placeholder="Username" value="">
</p>
<p class="submit">
<input type="hidden" name="action" value="register_handler">
<input type="hidden" name="jnews_nonce" value="">
<input type="submit" name="jeg_login_button" class="button" value="Sign Up" data-process="Processing . . ." data-string="Sign Up">
</p>
<div class="bottom_links clearfix">
<span>All fields are required.</span>
<a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
</div>
</form>
</div>
</div>

<div id="jeg_forgotform" class="jeg_popup mfp-with-anim mfp-hide">
<div class="jeg_popupform">
<form action="#" method="post" accept-charset="utf-8">
<h3>Retrieve your password</h3>
<p>Please enter your username or email address to reset your password.</p>

<div class="form-message"></div>
<p class="input_field">
<input type="text" name="user_login" placeholder="Your email or username" value="">
</p>
<p class="submit">
<input type="hidden" name="action" value="forget_password_handler">
<input type="hidden" name="jnews_nonce" value="">
<input type="submit" name="jeg_login_button" class="button" value="Reset Password" data-process="Processing . . ." data-string="Reset Password">
</p>
<div class="bottom_links clearfix">
<a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
</div>
</form>
</div>
</div><script type="text/javascript">var jfla=["view_counter","desktop_login","login_form"]</script><div class="et_bloom_popup et_bloom_optin et_bloom_resize et_bloom_optin_1 et_bloom_auto_popup et_bloom_scroll" data-delay="3" data-scroll_pos="25">
<div class="et_bloom_form_container et_bloom_popup_container et_bloom_form_bottom with_edge wedge_edge et_bloom_rounded et_bloom_form_text_dark et_bloom_animation_fadein">
<div class="et_bloom_form_container_wrapper clearfix">
<div class="et_bloom_header_outer">
<div class="et_bloom_form_header et_bloom_header_text_light">
<img src="https://stockwatch247.com/wp-content/uploads/2020/04/e1a55323a4381576589644-marketnews-logo.png" alt="Get Our Next Exclusive NASDAQ and NYSE Trade Report on Stocks with Big Upside Potential for FREE!" class=" et_bloom_image_slideup et_bloom_image">
<div class="et_bloom_form_text">
<h2 style="text-align: center; font-size: 20px !important;">Get Our Next Exclusive NASDAQ and NYSE Trade Report on Stocks with Big Upside Potential for FREE!</h2><p style="text-align: center;">Join our mailing list to receive the latest news and updates from our team.</p>
</div>
</div>
</div>
<div class="et_bloom_form_content et_bloom_1_field et_bloom_bottom_inline">
<svg class="triangle et_bloom_default_edge" xmlns="http://www.w3.org/2000/svg" version="1.1" width="100%" height="20" viewBox="0 0 100 100" preserveAspectRatio="none">
<path d="M0 0 L50 100 L100 0 Z" fill=""></path>
</svg>
<form method="post" class="clearfix">
<div class="et_bloom_fields">
<p class="et_bloom_popup_input et_bloom_subscribe_email">
<input placeholder="Email">
</p>
<button data-optin_id="optin_1" data-service="icontact" data-list_id="16551" data-page_id="29018" data-account="stockwat247" data-ip_address="true" class="et_bloom_submit_subscription">
<span class="et_bloom_subscribe_loader"></span>
<span class="et_bloom_button_text et_bloom_button_text_color_light">SUBSCRIBE!</span>
</button>
</div>
</form>
<div class="et_bloom_success_container">
<span class="et_bloom_success_checkmark"></span>
</div>
<h2 class="et_bloom_success_message">You have Successfully Subscribed!</h2>
<div class="et_bloom_form_footer"><p style="text-align: center;"><span style="color: #ffffff;">*By clicking "<strong>Subscribe Now</strong>" you agree to our <span style="color: #00ff00;"><a style="color: #00ff00;" href="../privacy-policy/">Privacy Policy</a></span> & <span style="color: #00ff00;"><a style="color: #00ff00;" href="../disclaimer/">Disclaimer</a></span> . We're 100% Anti-Spam.</span></p></div>
</div>
</div>
<span class="et_bloom_close_button"></span>
</div>
</div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-138465547-1','auto');ga('send','pageview');</script>
<div class="jeg_read_progress_wrapper"></div><link crossorigin="anonymous" rel='stylesheet' id='et-gf-open-sans-css' href='https://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='et_bloom-css-css' href='https://stockwatch247.com/wp-content/plugins/bloom/css/style.css?ver=1.3.10' type='text/css' media='all' />
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.11'></script>
<script type='text/javascript'>//<![CDATA[
var wpcf7={"apiSettings":{"root":"https:\/\/stockwatch247.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
//]]></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript'>//<![CDATA[
var jnewsoption={"popup_script":"disable","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","lang":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"29018","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":""};
//]]></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=4.0.6'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/jnews-split/assets/js/jquery.split.js'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript'>var mejsL10n={"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.13-9993131'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.4.1'></script>
<script type='text/javascript'>//<![CDATA[
var _wpmejsSettings={"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
//]]></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=4.0.6'></script>
<![endif]-->
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/bloom/core/admin/js/common.js?ver=3.20.2'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/jnews-weather/assets/js/plugin.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/bloom/js/jquery.uniform.min.js?ver=1.3.10'></script>
<script type='text/javascript'>//<![CDATA[
var bloomSettings={"ajaxurl":"https:\/\/stockwatch247.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/stockwatch247.com\/2020\/05\/21\/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north\/","stats_nonce":"82f2e25d73","subscribe_nonce":"075bd87258","is_user_logged_in":"not_logged"};
//]]></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/bloom/js/custom.js?ver=1.3.10'></script>
<script type='text/javascript' src='https://stockwatch247.com/wp-content/plugins/bloom/js/idle-timer.min.js?ver=1.3.10'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/stockwatch247.com\/2020\/05\/21\/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north\/"},"dateCreated":"2020-05-21 07:21:24","datePublished":"2020-05-21 07:21:24","dateModified":"2020-05-21 11:21:24","url":"https:\/\/stockwatch247.com\/2020\/05\/21\/are-shares-in-raytheon-technologies-corporation-rtx-ready-for-a-move-north\/","headline":"Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?","name":"Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?","articleBody":"Raytheon Technologies Corporation (RTX), a Industrials Aerospace & Defense corporation, saw its stock exchange 9,885,587 common shares, a higher demand when compared to its 10-day trading volume of 15.5M. Raytheon Technologies Corporation (RTX) stock is trading at $57.80, down -0.14 cents or -0.24% on the day. Based on this we can see some traders are either waiting on the sidelines to get involved or perhaps some are taking losses. Total Revenue for Raytheon Technologies Corporation (RTX) is $76.89B. Gross Profit is $20.21B and the EBITDA is $13.84B. <br\/><br\/><h4>Raytheon Technologies Corporation (RTX) Technical Statistics: <\/h4><br\/><br\/><br\/>The average 10-day trading volume of Raytheon Technologies Corporation (RTX) is 15.5M compared to 16.37M over the last 3 months which indicates a lower demand in trading activity. Right now, Raytheon Technologies Corporation (RTX) has a 50-day moving average of $60.16 and a 200-day moving average of $81.03. These moving averages are popular technical statistics that investors use to analyze price trends of Raytheon Technologies Corporation (RTX). Approximately 1.20% of the shares of the company are short sold from traders betting the shares will trade lower. The beta value of Raytheon Technologies Corporation (RTX) stock is 1.45, indicating its 4.26% to 3.72% more volatile than the overall marketplace. <br\/><br\/> RTX is trading 41.98% off its 52 week low at $40.71  and -38.15% off its 52 week high of $93.45. Performance wise, RTX stock has recently shown investors 6.84% a higher demand in a week, -7.74% a lower demand in a month and -34.63% a lower demand in the past quarter.  More importantly, Raytheon Technologies Corporation (RTX) has shown a return of -34.56% since the start of the year.<br\/><br\/><h4>Raytheon Technologies Corporation (RTX) Key Data: <\/h4><br\/><br\/>Raytheon Technologies Corporation (RTX) is a large-cap company with a market cap value of $87.576B. RTX insiders hold roughly 0.11% of the shares. On Apr-08-20 Vertical Research Initiated RTX as Hold at $58. On Apr-15-20 JP Morgan Downgrade RTX as Overweight \u2192 Neutral  and on Apr-15-20 Goldman Resumed RTX as Buy at $76.<br\/><br\/>There are currently 1.51B shares in the float and 858.40M shares outstanding. There are 1.20% shares short in RTXs float. The industry rank for Raytheon Technologies Corporation (RTX) is 205 out of 254 ranking it at the Bottom 19% . <br\/><br\/><h4>Raytheon Technologies Corporation (RTX) Fundamental Evaluation: <\/h4><br\/><br\/>RTX last 2 years revenues have decreased from $77,046,000 to $76,891,000 showing a downtrend.  Wall Street expects Raytheon Technologies Corporation (RTX) to report an EPS next Qtr profit of  0.30 and a profit of  31.07% next year. The growth rate on RTX this year is -57.51 compared to an industry -12.00.  RTXs next year's growth rate is 10.54 compared to an industry 6.50.  The book value per share (mrq) is 45.91 and cash per share (mrq) is 5.17.  Giving them a price\/book (mrq) of 1.20 compared to an industry of 1.67  and RTXs price\/cash flow (mrfy) is 4.58 compared to an industry of 5.62.  RTX fundamental ratios shows an EPS growth vs. previous year 3.51 and EPS growth vs. previous quarter 0.39. ","author":{"@type":"Person","name":"stockwatch247","url":"https:\/\/stockwatch247.com\/author\/stockwatch247\/"},"articleSection":["Small Cap"],"image":{"@type":"ImageObject","url":"https:\/\/stockwatch247.com\/wp-content\/uploads\/2019\/04\/young-manager-has-received-good-bad-news-UGBDSNX.jpg","width":3000,"height":2000},"publisher":{"@type":"Organization","name":"","url":"https:\/\/stockwatch247.com","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/web.facebook.com\/StockWatch247-1627886234022309","https:\/\/twitter.com\/StockWatch247"]}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Are Shares In Raytheon Technologies Corporation (RTX) Ready For A Move North?","published":"2020-05-21 07:21:24","updated":"2020-05-21 11:21:24"}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/stockwatch247.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/stockwatch247.com\/category\/small-cap\/","name":"Small Cap"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/stockwatch247.com","name":"Home"}},{"@type":"ListItem","position":4,"item":{"@id":"https:\/\/stockwatch247.com\/category\/small-cap\/","name":"Small Cap"}}]}</script>
</body>
</html>
